Product Support

All products are available as Download only. The download link is provided via mail after purchase.

System Requirements

Mac OS X

OS X 10.7 or later (Plugins are not yet tested with High Sierra)
1 GHz Intel CPU or better
Host software that is compatible with 32 or 64-bit VST 2.4 or Audio Unit

Windows

Windows 7 or later
1 GHz Intel CPU or better
Host software that is compatible with 32 or 64-bit VST 2.4

Contact

If you experience a problem with the product please contact us using the form below

Make sure to provide a detailed description of the environment you are using along with a detailed description of the problem.